QPoint2dBuffer.unquantizePoint Function
Extracts and unquantizes the point at the specified index from a buffer.
unquantizePoint(buffer: QPoint2dBuffer, pointIndex: number, result?: Point2d): Point2d
@returns The point at pointIndex
.
@throws Error if pointIndex
is out of bounds.
Parameter | Type | Description |
---|---|---|
buffer | QPoint2dBuffer | The array of points and the quantization parameters. |
pointIndex | number | |
result | Point2d | If supplied, a preallocated Point2d to initialize with the result and return. |
Returns - Point2d
The point at pointIndex
.
Defined in
- core/common/src/QPoint.ts Line 302
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.