multiplyTransform Method
Multiply the Transform of this Placement3d by the specified other Transform.
- Specifically
this.angles
is set to the rotation specified byother.matrix * this.transform.matrix
andthis.origin
is set to the origin ofother * this.transform
. - Since the placement transform is local-to-world, this means
other
is a world-to-world transform.
multiplyTransform(other: Transform): void
@throws IModelError if the Transform is invalid for a GeometricElement3d.
Parameter | Type | Description |
---|---|---|
other | Transform |
Returns - void
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.