appendGeometryPart3d Method
Append a GeometryPart instance with relative position, orientation, and scale to a GeometryStreamProps array for creating a GeometricElement3d. Not valid when defining a GeometryPart as nesting of parts is not supported.
appendGeometryPart3d(partId: string, instanceOrigin?: Point3d, instanceRotation?: YawPitchRollAngles, instanceScale?: number): boolean
Parameter | Type | Description |
---|---|---|
partId | string | |
instanceOrigin | Point3d | |
instanceRotation | YawPitchRollAngles | |
instanceScale | number |
Returns - boolean
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.