ModelQueryParams Interface
Parameters for performing a query on Model classes.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
wantPrivate | boolean | undefined | ||
wantTemplate | boolean | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
bindings Inherited | object | any[] | EntityQueryParams | Bindings for parameterized values. |
from Inherited | string | undefined | EntityQueryParams | The sql className, in the form "Schema.ClassName", of the class to search. |
limit Inherited | number | undefined | EntityQueryParams | Optional "LIMIT" clause to limit the number of rows returned. |
offset Inherited | number | undefined | EntityQueryParams | Optional "OFFSET" clause. |
only Inherited | boolean | undefined | EntityQueryParams | Set to true to limit results to not include sub-classes of "from" class |
orderBy Inherited | string | undefined | EntityQueryParams | Optional "ORDERBY" clause to sort results. |
where Inherited | string | undefined | EntityQueryParams | Optional "WHERE" clause to filter entities. |
Defined in
- core/common/src/ModelProps.ts Line 42
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.