ChangedElements Interface
Changed elements found in a changeset or between a range of changesets. All arrays in this object will have the same number of items. Each index for those arrays refer to the same element, e.g. to get the class Id of the element given by element Id changedElements.elements[index], you can use changedElements.classIds[index].
Properties
Name | Type | Description | |
---|---|---|---|
classIds | string[] | ECClass Ids of elements that changed | |
elements | string[] | Ids of elements that changed | |
modelIds | string[] | undefined | Model Ids of the changed elements | |
newChecksums | number[][] | undefined | After state checksums of the property value | |
oldChecksums | number[][] | undefined | Before state checksums of the property value | |
opcodes | DbOpcode[] | Operation that occurred on the element. | |
parentClassIds | string[] | undefined | Parent ECClass Ids of the changed elements | |
parentIds | string[] | undefined | Parent ids of the changed elements | |
properties | string[][] | undefined | Property accessor strings of properties that changed, if any, for each changed element | |
type | TypeOfChange[] | Type of change bitflags, see TypeOfChange |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.