toJsName MethodStatic

Formats the specified ECProperty name according to the iTwin.js formatting rules.

See ECSQL Row Format which describes the formatting rules.

toJsName(propName: string, isSystemProperty?: boolean): string

Parameter Type Description
propName string  
isSystemProperty boolean if omitted, the method will try to find out whether the given property
is a system property or not. If true is specified, the method will throw if the property name
is not a known system property. If false is specified, the method will not attempt to recognize
the property name as system property.

Returns - string

Defined in

Last Updated: 21 November, 2024