with Method
Produce a copy of these ViewFlags with a single boolean property changed.
with(flag: "fill" | "transparency" | "dimensions" | "patterns" | "weights" | "styles" | "textures" | "materials" | "acsTriad" | "grid" | "visibleEdges" | "hiddenEdges" | "shadows" | "clipVolume" | "constructions" | "monochrome" | "backgroundMap" | "ambientOcclusion" | "thematicDisplay" | "wiremesh" | "forceSurfaceDiscard" | "whiteOnWhiteReversal" | "lighting", value: boolean): ViewFlags
@returns A new ViewFlags with the property changed as specified, or this
if the property already has the specified value.
@see - withRenderMode to change the renderMode property.
Returns - ViewFlags
A new ViewFlags with the property changed as specified, or this
if the property already has the specified value.
Defined in
- core/common/src/ViewFlags.ts Line 309
Last Updated: 21 November, 2024