fromJSON MethodStatic
Create a ViewFlags from its JSON representation.
fromJSON(json?: ViewFlagProps): ViewFlags
@note As described in ViewFlagProps, the JSON representation is awkward and error-prone. Prefer to use create unless you need to deal with the persistence format directly.
@note The default values differ slightly from those used by the constructor and create:
- clipVolume defaults to false.
- constructions defaults to true.
- lighting defaults to true unless all of noSolarLight, noCameraLights, and noSourceLights are true.
Parameter | Type | Description |
---|---|---|
json | ViewFlagProps |
Returns - ViewFlags
Defined in
- core/common/src/ViewFlags.ts Line 473
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.