clone Method
Create a copy of this TerrainSettings, optionally modifying some of its properties.
clone(changedProps?: PlanarClipMaskProps): PlanarClipMaskSettings
@returns A PlanarClipMaskSettings with all of its properties set to match those ofthis
, except those explicitly defined in changedProps
.
Parameter | Type | Description |
---|---|---|
changedProps | PlanarClipMaskProps | JSON representation of the properties to change. |
Returns - PlanarClipMaskSettings
A PlanarClipMaskSettings with all of its properties set to match those ofthis
, except those explicitly defined in changedProps
.
Defined in
- core/common/src/PlanarClipMask.ts Line 248
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.