HiddenLine.StyleProps Interface
Describes the symbology with which edges should be drawn. This JSON representation is awkward, but it must match that used in the db. If the JSON came from the db then all members are present and:
- color is overridden only if ovrColor = true.
- width is overridden only if width != 0
- pattern is overridden only if pattern != LinePixels.Invalid The 'public' JSON representation is more sensible:
- Color, width, and pattern are each overridden iff they are not undefined. To make this work for both scenarios, the rules are:
- color is overridden if color != undefined and ovrColor != false
- width is overridden if width != undefined and width != 0
- pattern is overridden if pattern != undefined and pattern != LinePixels.Invalid
Properties
Name | Type | Description | |
---|---|---|---|
color | number | undefined | If defined, and HiddenLine.StyleProps.ovrColor is not false , the color used to draw the edges. |
|
ovrColor | boolean | undefined | If true, and HiddenLine.StyleProps.color is defined, then the edge color is overridden. | |
pattern | LinePixels | undefined | If defined and not equal to Invalid, the pixel pattern used to draw the edges. | |
width | number | undefined | If defined and non-zero, the width of the edges in pixels. |
Defined in
- core/common/src/HiddenLine.ts Line 30
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.