ElementPlanarClipMaskArgs Interface
Arguments supplied to PlanarClipMaskSettings.create to create a mask of IncludeElements or ExcludeElements.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
elementIds | Iterable<string, any, any> | The elements used by the mask. | |
exclude | boolean | undefined | If true, creates a mask of ExcludeElements; otherwise, IncludeElements. | |
modelIds | Iterable<string, any, any> | undefined | See modelIds. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
invert Inherited | boolean | undefined | BasicPlanarClipMaskArgs | See PlanarClipMaskSettings.invert. |
transparency Inherited | number | undefined | BasicPlanarClipMaskArgs | See transparency. |
Defined in
- core/common/src/PlanarClipMask.ts Line 107
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.