itwin.js logoiTwin.js
DocumentationAPICommunity Sandboxes
v4.x
Change Historyv3.xv2.xv1.x

    Core Packages

    • core-frontend

      • IModelApp
      • IModelConnection
      • ElementState
      • ModelState
      • Tools
      • Measure
      • Views
      • LocatingElements
      • AccuDraw
      • Notifications
      • Properties
      • Rendering
      • SelectionSet
      • NativeApp
      • Utils
      • Logging
      • QuantityFormatting
      • Tiles
      • HubAccess
      • UserPreferences
      • MapLayers
      • TileStorage
      • All
    • core-backend

      • BlobContainers
      • Codes
      • ECDb
      • ECSQL
      • ElementAspects
      • ElementGeometry
      • Elements
      • ExportGraphics
      • HubAccess
      • IModelHost
      • iModels
      • Logging
      • Models
      • NativeApp
      • Portability
      • Relationships
      • RpcInterface
      • Schema
      • SQLite
      • SQLiteDb
      • TileStorage
      • ViewDefinitions
      • Workspace
      • All
    • core-common

      • Entities
      • Codes
      • Geometry
      • Views
      • DisplayStyles
      • Rendering
      • Symbology
      • iModels
      • RpcInterface
      • IpcSocket
      • ECSQL
      • Logging
      • Tween
      • Tile
      • Utils
      • NativeApp
      • Localization
      • Authorization
      • RealityData
      • MapLayers
      • Annotation
      • All
    • core-bentley

      • BeSQLite
      • Errors
      • Events
      • Ids
      • Logging
      • Collections
      • Json
      • Utils
      • ProcessDetector
      • All
    • core-geometry

      • CartesianGeometry
      • ArraysAndInterfaces
      • Bspline
      • Curve
      • Numerics
      • Polyface
      • Serialization
      • Solid
      • Topology
      • RangeSearch
      • All
    • core-electron

      • Renderer
      • Main
      • RpcInterface
      • All
    • core-markup

      • MarkupApp
      • MarkupTools
      • All
    • core-mobile

      • MobileApp
      • MobileAppProps
      • MobileHost
      • MobileRpcServer
      • iModelHub
      • All
    • core-i18n

      • Localization
      • All
    • core-quantity

      • Quantity
      • All
    • ecschema-editing

      • Editing
      • Diagnostic
      • Validation
      • Comparison
      • Merging
      • All
    • ecschema-locaters

      • Locaters
      • Utils
      • All
    • ecschema-metadata

      • Metadata
      • Utils
      • Context
      • SchemaJsonLocater
      • SchemaLoader
      • SchemaPartVisitorDelegate
      • SchemaUnitProvider
      • All
    • frontend-devtools

      • Widgets
      • Tools
      • Controls
      • Effects
      • Utilities
      • All
    • hypermodeling-frontend

      • HyperModeling
      • All
    • webgl-compatibility

      • Compatibility
      • All
    • map-layers-formats

      • MapLayersFormats
      • All

    Editor Packages

    • editor-backend

      • Editing
      • All
    • editor-common

      • Editing
      • All
    • editor-frontend

      • Editing
      • All

    UI Packages

    • appui-abstract

      • Backstage
      • ContentView
      • Dialog
      • Item
      • Notification
      • Properties
      • StatusBar
      • Toolbar
      • UiAdmin
      • UiItemsProvider
      • Utilities
      • Widget
      • All
    • core-react

      • AutoSuggest
      • Base
      • Button
      • Checkbox
      • CheckListBox
      • Common
      • ContextMenu
      • Dialog
      • ElementSeparator
      • Expandable
      • Icon
      • Inputs
      • Listbox
      • Loading
      • Notification
      • Popup
      • RadialMenu
      • SearchBox
      • Settings
      • Tabs
      • Text
      • Tree
      • UiStateStorage
      • Utilities
      • All
    • components-react

      • Common
      • Favorite
      • Filtering
      • Inputs
      • SelectableContent
      • Properties
      • PropertyEditors
      • PropertyGrid
      • Toolbar
      • Tree
      • TypeConverters
      • PropertyFilterBuilder
      • All
    • imodel-components-react

      • Color
      • Common
      • Cube
      • Inputs
      • LineWeight
      • NavigationAids
      • PropertyEditors
      • Timeline
      • Viewport
      • All
    • appui-react

      • AccuDraw
      • Admin
      • Backstage
      • ConfigurableUi
      • ContentView
      • Cursor
      • Dialog
      • Frontstage
      • Hooks
      • Item
      • KeyboardShortcut
      • NavigationAids
      • Notification
      • ChildWindowManager
      • Picker
      • Popup
      • State
      • Settings
      • StandardUiItemsProvider
      • StatusBar
      • SyncUi
      • Timeline
      • Toolbar
      • Tools
      • ToolSettings
      • UiProvider
      • UiStateStorage
      • Utilities
      • Widget
      • All

    Presentation Packages

    • presentation-common

      • Core
      • RPC
      • UnifiedSelection
      • Content
      • Hierarchies
      • PresentationRules
      • All
    • presentation-components

      • Core
      • Logging
      • Properties
      • PropertyGrid
      • FavoriteProperties
      • Tree
      • Table
      • Viewport
      • DisplayLabels
      • UnifiedSelection
      • InstancesFilter
      • All
    • presentation-backend

      • Core
      • Logging
      • All
    • presentation-frontend

      • Core
      • Logging
      • UnifiedSelection
      • All

    Domain Packages

    • analytical-backend

      • Analytical
      • All
    • linear-referencing-backend

      • LinearReferencing
      • All
    • linear-referencing-common

      • LinearReferencing
      • All
    • physical-material-backend

      • PhysicalMaterial
      • All

    Transformer

    • imodel-transformer

      • iModels
      • Logging
      • All

    Connector Framework

    • connector-framework

      • Args
      • BaseConnector
      • ConnectorIssueReporter
      • ConnectorRunner
      • Framework
      • Logging
      • SqliteIssueReporter
      • ConnectorAuthenticationManager
      • ChangeSetGroup
      • iModelConnectorErrors
      • SyncErrors
      • All

    Authorization

    • browser-authorization

      • Authorization
      • Logging
      • All
    • electron-authorization

      • Main
      • Renderer
      • All
    • node-cli-authorization

      • Authorization
      • All
    • service-authorization

      • Authorization
      • Logging
      • All
API Reference › core-common› DisplayStyles › AnalysisStyleDisplacementProps

AnalysisStyleDisplacementProps Interface

JSON representation of an AnalysisStyleDisplacement.

@see displacement.

Properties

Name Type Description
channelName string See channelName.  
scale number | undefined See AnalysisStyleDisplacement.scale.  

Defined in

  • core/common/src/AnalysisStyle.ts Line 18

Last Updated: 30 April, 2025

Found something wrong, missing, or unclear on this page? Raise an issue in our repo.
itwin.js logoiTwin.js

Driven by the community and powered by Bentley

iTwin.js on TwitteriTwin.js on Stack OverflowiTwin.js on Github