TextBlockProps Interface
JSON representation of a TextBlock.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
justification | TextBlockJustification | undefined | The alignment of the document content. | |
paragraphs | ParagraphProps[] | undefined | The paragraphs within the text block. | |
width | number | undefined | The width of the document in meters. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
styleName Inherited | string | TextBlockComponentProps | The name of a TextStyle stored in a Workspace from which the base TextStyleSettings applied to the component originates. |
styleOverrides Inherited | TextStyleSettingsProps | undefined | TextBlockComponentProps | Deviations from the base TextStyleSettings defined by the TextStyle applied to this component. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.