getErrorMetadata MethodStatic
Use run-time type checking to safely get the metadata with an unknown error value, if possible.
getErrorMetadata(error: unknown): undefined | object
@note It's recommended to use this function in catch
clauses, where a caught value cannot be assumed to be instanceof BentleyError
@see getMetaData
Parameter | Type | Description |
---|---|---|
error | unknown |
Returns - undefined | object
Defined in
- core/bentley/src/BentleyError.ts Line 681
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.