getErrorMessage MethodStatic
Use run-time type checking to safely get a useful string summary of an unknown error value, or ""
if none exists.
getErrorMessage(error: unknown): string
@note It's recommended to use this function in catch
clauses, where a caught value cannot be assumed to be instanceof Error
Parameter | Type | Description |
---|---|---|
error | unknown |
Returns - string
Defined in
- core/bentley/src/BentleyError.ts Line 643
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.