append Method
Pushes a value onto the back of the queue without making any attempt to enforce ordering. After using this function, you must manually invoke sort() to ensure the queue is sorted again.
append(value: T): T
@returns The appended value, cloned according to the CloneFunction supplied to this queue's constructor.
Parameter | Type | Description |
---|---|---|
value | T | The value to append |
Returns - T
The appended value, cloned according to the CloneFunction supplied to this queue's constructor.
Defined in
- core/bentley/src/PriorityQueue.ts Line 111
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.