WorkspaceDbQueryResourcesArgs Interface

Arguments supplied to queryResources.

Properties

Name Type Description
callback WorkspaceDbQueryResourcesCallback A function invoked to process the resources that match the query criterion.  
nameCompare "GLOB" | "LIKE" | "NOT GLOB" | "NOT LIKE" | "=" | "<" | ">" The comparison operator by which to compare the name of each resource to namePattern.  
namePattern string | undefined A pattern against which to compare the name of each resource, using nameCompare as the comparison operator.  
type "string" | "blob" The type of resource to query.  

Defined in

Last Updated: 21 November, 2024