WorkspaceDbLoadError Interface

An exception thrown when attempting to load a WorkspaceDb or some of its data; for example, if the WorkspaceDb could not be found or the user is not authorized to access its WorkspaceContainer.

Extends

  • Error

Properties

Name Type Description
wsDb WorkspaceDb | undefined The WorkspaceDb in which the error occurred, if available.  
wsDbProps WorkspaceDbProps & Partial<WorkspaceDbCloudProps> | undefined The properties of the WorkspaceDb that was attempted to load, including the identity of its WorkspaceContainer.  

Defined in

Last Updated: 21 November, 2024