CloudSqlite.parseDbFileName Function
Parse the name of a Db stored in a CloudContainer into the dbName and version number. A single CloudContainer may hold many versions of the same Db. The name of the Db in the CloudContainer is in the format "name:version". This function splits them into separate strings.
parseDbFileName(dbFileName: string): { dbName: CloudSqlite.DbName, version: CloudSqlite.DbVersion }
Parameter | Type | Description |
---|---|---|
dbFileName | string |
Returns - { dbName: CloudSqlite.DbName, version: CloudSqlite.DbVersion }
Defined in
- core/backend/src/CloudSqlite.ts Line 861
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.