CloudSqlite.LoadProps Interface
Specifies the name and version of a CloudSqlite database.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
container Readonly | CloudSqlite.CloudContainer | ||
includePrerelease Readonly | boolean | undefined | If true, allow semver prerelease versions, e.g., "1.4.2-beta.0". | |
prefetch Readonly | boolean | undefined | If true, start a prefetch operation whenever this database is opened, to begin downloading pages of the database before they are needed. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
dbName Readonly Inherited | string | CloudSqlite.DbNameAndVersion | The name of the database |
version Readonly Inherited | string | undefined | CloudSqlite.DbNameAndVersion | The range of acceptable versions of the database of the specified DbNameAndVersion.dbName. |
Defined in
- core/backend/src/CloudSqlite.ts Line 290
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.