CloudSqlite.addHiddenProperty Function
Add (or replace) a property to an object that is not enumerable. This is important so this member will be skipped when the object is the target of structuredClone (e.g. when the object is part of an exception that is marshalled across process boundaries.)
addHiddenProperty<T>(o: T, p: PropertyKey, value?: any): T
Parameter | Type | Description |
---|---|---|
o | T | |
p | PropertyKey | |
value | any |
Returns - T
Defined in
- core/backend/src/CloudSqlite.ts Line 42
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.