readSchemaFromXmlFile Method
Deserialize a Schema from an ECSchemaXML-formatted file.
readSchemaFromXmlFile(filePath: string): any
@returns The JSON representation of the schema, as a SchemaProps.
@throws IModelError if there is a problem reading schema from the XML file
Parameter | Type | Description |
---|---|---|
filePath | string | The absolute path of the XML file. |
Returns - any
The JSON representation of the schema, as a SchemaProps.
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.