BisCoreSchema Class
The BisCore schema is the lowest level Schema in an iModel.
It is automatically registered when startup is called.
Example:
// Make sure somewhere in your startup code you call: IModelHost.startup()
// Get the JavaScript class for the "Element" BIS Class
const elementClass = ClassRegistry.findRegisteredClass("BisCore:Element")!;
assert.equal("BisCore", elementClass.schema.schemaName);
assert.equal("Element", elementClass.className);
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
toSemverString(paddedVersion: string): string Static Inherited | Schema | Get a semver-compatible string from a padded version string. |
Properties
Name | Type | Description | |
---|---|---|---|
schemaFilePath Accessor Static ReadOnly | string | ||
schemaName Accessor Static ReadOnly | string | The name of the BIS schema handled by this Schema. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.