createCode MethodStatic
Create a Code for a SpatialCategory given a name that is meant to be unique within the scope of the specified DefinitionModel.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code
@returns A spatial category Code
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The IModel |
scopeModelId | string | The Id of the DefinitionModel that contains the SpatialCategory and provides the scope for its name. |
codeValue | string | The name of the category |
Returns - Code
A spatial category Code
Defined in
- core/backend/src/Category.ts Line 217
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.