releaseAllLocks Method
Release all locks currently held by this briefcase from the locker server. This is typically done on your behalf by pushChanges. You may want to do it manually when abandoning all of your briefcase's local changes. You cannot release your locks if your briefcase contains local changes.
releaseAllLocks(): Promise<void>
@throws Error if the briefcase has local changes, or if any other error occurs while releasing the locks.
Returns - Promise
Defined in
- core/backend/src/LockControl.ts Line 80
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.