validateSchemas MethodStatic
Determines if the schemas in the Db must or can be upgraded by comparing them with those included in the current version of the software.
validateSchemas(filePath: string, forReadWrite: boolean): SchemaState
@throws IModelError If the Db was in an invalid state and that causes a problem with validating schemas
@see - upgradeSchemas or upgradeSchemas
- ($docs/learning/backend/IModelDb.md#upgrading-schemas-in-an-imodel)
Returns - SchemaState
Defined in
- core/backend/src/IModelDb.ts Line 981
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.