getMetaData Method
Deprecated in 5.0. Please use getSchemaItem
from SchemaContext
class instead.
Get metadata for a class. This method will load the metadata from the iModel into the cache as a side-effect, if necessary.
getMetaData(classFullName: string): EntityMetaData
@throws IModelError if the metadata cannot be found nor loaded.
@example * ```typescript // Current usage: const metaData: EntityMetaData = imodel.getMetaData("SchemaName:ClassName");
// Replacement: const metaData: EntityClass | undefined = imodel.schemaContext.getSchemaItemSync("SchemaName", "ClassName", EntityClass);
```
Parameter | Type | Description |
---|---|---|
classFullName | string |
Returns - EntityMetaData
Defined in
- core/backend/src/IModelDb.ts Line 1173
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.