getLastError Method
Returns a string representation of the error that most recently arose during an operation on the underlying SQLite database.
If no errors have occurred, an empty string is returned.
Otherwise, a string of the format message (code)
is returned, where message
is a human-readable diagnostic string and code
is an integer status code.
See SQLite error codes and messages
getLastError(): string
@note Do not rely upon this value or its specific contents in error handling logic. It is only intended for use in debugging.
Returns - string
Defined in
- core/backend/src/IModelDb.ts Line 1564
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.