forEachMetaData Method
Deprecated in 5.0. Use forEachProperty
from SchemaContext
class instead.
Invoke a callback on each property of the specified class, optionally including superclass properties.
forEachMetaData(classFullName: string, wantSuper: boolean, func: PropertyCallback, includeCustom: booleantrue): void
@note Custom-handled properties are core properties that have behavior enforced by C++ handlers.
@example
// Current usage:
iModel.forEachMetaData("BisCore:Element", true, (name: string, propMetaData: PropertyMetaData) => {
console.log(`Property name: ${name}, Property type: ${propMetaData.primitiveType}`);
});
// Replacement:
imodel.schemaContext.forEachProperty("BisCore:Element", true, (propName: string, property: Property) => {
console.log(`Property name: ${propName}, Property type: ${property.propertyType}`);
});
Parameter | Type | Description |
---|---|---|
classFullName | string | The full class name to load the metadata, if necessary |
wantSuper | boolean | If true, superclass properties will also be processed |
func | PropertyCallback | The callback to be invoked on each property |
includeCustom | boolean | If true (default), include custom-handled properties in the iteration. Otherwise, skip custom-handled properties. |
Returns - void
Defined in
- core/backend/src/IModelDb.ts Line 1259
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.