getChangedPropertyValueNames MethodStatic
Retrieves the names of the properties whose values have changed for the given instance change
See also Change Summary Overview
getChangedPropertyValueNames(iModel: IModelDb, instanceChangeId: string): string[]
@returns Returns names of the properties whose values have changed for the given instance change
@throws IModelError if the change cache file hasn't been attached, or in case of other errors.
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | iModel |
instanceChangeId | string | Id of the InstanceChange to query the properties whose values have changed |
Returns - string[]
Returns names of the properties whose values have changed for the given instance change
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.