CatalogDb.acquireWriteLock Function
Acquire the write lock for a CatalogIModel container. Only one person may obtain the write lock at a time. You must obtain the lock before attempting to write to the container via functions like openEditable and createNewVersion.
acquireWriteLock(args: { containerId: string, username: string }): Promise<void>
@note This requires "write" authorization to the container
Parameter | Type | Description |
---|---|---|
args | { containerId: string, username: string } |
Returns - Promise
Defined in
- core/backend/src/CatalogDb.ts Line 224
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.