serialize MethodStatic @beta
Converts an EntityProps to an ECSqlRow. This is used to serialize an Entity to prepare to write it to the database.
serialize(props: GeometricElement2dProps, iModel: IModelDb): ECSqlRow
Parameter | Type | Description |
---|---|---|
props | GeometricElement2dProps | |
iModel | IModelDb |
Returns - ECSqlRow
Defined in
- core/backend/src/Element.ts Line 866
Last Updated: 09 May, 2025
Found something wrong, missing, or unclear on this page? Raise an issue in our repo.