onChildDelete MethodProtected Static
Called when an element with an instance of this class as its parent is about to be deleted.
onChildDelete(_arg: OnChildElementIdArg): void
@note throw an exception if the element should not be deleted
@note implementers should not presume that the element was deleted if this method does not throw, since the delete may fail for other reasons. Instead, rely on onChildDeleted for that purpose.
@note this
is the class of the parent Element whose child will be deleted
Parameter | Type | Description |
---|---|---|
_arg | OnChildElementIdArg |
Returns - void
Defined in
- core/backend/src/Element.ts Line 219
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.