onBeforeOutputsHandled MethodProtected Static
Called when a root element in a subgraph is changed and before its outputs are processed. This special callback is made when:
- the element is part of an ElementDrivesElement graph, and
- the element has no inputs, and
- none of the element's outputs have been processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void
@see ElementDrivesElement for more on element dependency graphs.
Parameter | Type | Description |
---|---|---|
_id | string | |
_iModel | IModelDb |
Returns - void
Defined in
- core/backend/src/Element.ts Line 324
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.