insert MethodStatic

Insert a Drawing element and a DrawingModel that breaks it down.

insert(iModelDb: IModelDb, documentListModelId: string, name: string, scaleFactor?: number): string

@returns The Id of the newly inserted Drawing element and the DrawingModel that breaks it down (same value).

@throws IModelError if unable to insert the element.

@throws Error if scaleFactor is less than or equal to zero.

Parameter Type Description
iModelDb IModelDb Insert into this iModel
documentListModelId string Insert the new Drawing into this DocumentListModel
name string The name of the Drawing.
scaleFactor number See scaleFactor. Must be greater than zero.

Returns - string

The Id of the newly inserted Drawing element and the DrawingModel that breaks it down (same value).

Defined in

Last Updated: 04 April, 2025