LineStyleDefinition.SymbolOptions Enumeration
Symbol options for location, orientation, and behavior
Members
Name |
Value |
Description |
AbsoluteRotation |
|
Angle of symbol not relative to stroke direction |
AdjustRotation |
|
Adjust symbol rotation left->right |
Center |
|
symbol at center of stroke |
CurveEnd |
|
Symbol at curve end point |
CurveOrigin |
|
Symbol at curve start point |
CurveVertex |
|
Symbol at each vertex |
End |
|
Symbol at end of stroke |
NoClip |
|
No clip on partial strokes |
None |
|
No point symbol |
NoPartial |
|
No partial strokes |
NoScale |
|
No scale on variable strokes |
Origin |
|
Symbol at origin of stroke |
ProjectOrigin |
|
Project partial origin |
UseColor |
|
Use color from symbol instead of inheriting curve color |
UseWeight |
|
Use weight from symbol instead of inheriting curve weight |
Defined in
Last Updated: 21 November, 2024