LineStyleDefinition.StrokePatternOptions Enumeration
Options to control how stroke pattern is applied to underlying curve
Members
Name | Value | Description |
---|---|---|
AutoPhase | LineStyleDefinition.StrokePatternProps.phase represents fractional distance into first stroke of pattern | |
CenterStretch | Center the line style and stretch the ends | |
Iteration | Use LineStyleDefinition.StrokePatternProps.maxIter to limit the number of iterations of the stroke pattern | |
None | Use default stroke behavior | |
Segment | Single segment mode restarts the stroke pattern at corners instead of continuing around corners |
Defined in
- core/backend/src/LineStyle.ts Line 109
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.