LineStyleDefinition.ComponentProps Interface
Identifies a component by file property id and type
Properties
Name | Type | Description | |
---|---|---|---|
id | number | The file property id of LineStyleDefinition.ComponentType.StrokePattern or LineStyleDefinition.ComponentType.StrokePoint component | |
offset | number | undefined | Offset distance for this component, default is 0 | |
type | LineStyleDefinition.ComponentType | The type of component for specified file property id |
Defined in
- core/backend/src/LineStyle.ts Line 260
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.