stepForInsert Method
Step this INSERT statement and returns status and the ECInstanceId of the newly created instance.
Insert statements can be used with ECDb only, not with IModelDb.
stepForInsert(): ECSqlInsertResult
@returns Returns the generated ECInstanceId in case of success and the status of the step call. In case of error, the respective error code is returned.
Returns - ECSqlInsertResult
Returns the generated ECInstanceId in case of success and the status of the step call. In case of error, the respective error code is returned.
Defined in
- core/backend/src/ECSqlStatement.ts Line 319
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.