updateIModel Method
Update the iModel with the results of converting an item to one or more Elements. If the item is new or changed, the conversion writes are written to the iModel and the associated ExternalSourceAspect is updated. If the item is known and unchanged, then the iModel is not updated. In either case, this function will record the id of the element as having been seen.
updateIModel(results: SynchronizationResults, sourceItem: SourceItem): IModelStatus
@see SourceItem for an explanation of how an entity from an external source is tracked.
Parameter | Type | Description |
---|---|---|
results | SynchronizationResults | The Element to be inserted or updated |
sourceItem | SourceItem | Whether the element is new, changed, or unchanged |
Returns - IModelStatus
Defined in
- Synchronizer.ts Line 439
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.