setActiveSelectionScope MethodStatic
Deprecated in 4.15.0. Use activeScope
prop of SelectionScopeField.
This method stores the active selection scope to the supplied scope id, and triggers
a SessionStateActionId.SetSelectionScope
event in the SyncUiEventDispatcher
.
Note: As of 4.0, this method does not change the active selection scope in the Presentation.selection.scopes.activeScope
property.
This event should be listened to and the change should typically be applied to
Presentation.selection.scopes.activeScope
property from the @itwin/presentation-frontend
package.
setActiveSelectionScope(selectionScopeId: string): void
@note Requires redux provider.
Parameter | Type | Description |
---|---|---|
selectionScopeId | string |
Returns - void
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.