getAvailableSelectionScopes MethodStatic
Deprecated in 4.15.0. Components should take selectionScopes
as a prop.
Returns the stored list of available selection scopes. This list should be set by the application
by dispatching the setAvailableSelectionScopes
action.
The value for this action typically come from Presentation.selection.scopes.getSelectionScopes()
method found in the @itwin/presentation-frontend
package.
getAvailableSelectionScopes(): PresentationSelectionScope[]
@note Returned value is immutable.
@note Requires redux provider.
Returns - PresentationSelectionScope[]
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.