getWidgets MethodStatic
Called when the application is populating the Stage Panels so that any registered UiItemsProvider can add widgets
getWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection): ReadonlyArray<ProviderItem<Widget>>
@returns An array of widgets.
Parameter | Type | Description |
---|---|---|
stageId | string | a string identifier of the active stage. |
stageUsage | string | the StageUsage of the active stage. |
location | StagePanelLocation | the location within the stage. |
section | StagePanelSection | the section within location. |
Returns - ReadonlyArray<ProviderItem<Widget>>
An array of widgets.
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.