floatWidget Method
Create a new floating panel that contains the widget specified by its Id.
floatWidget(widgetId: string, position?: Readonly<WritableXAndY>, size?: SizeProps): void
Parameter | Type | Description |
---|---|---|
widgetId | string | case sensitive Widget Id |
position | Readonly<WritableXAndY> | Position of top left corner of floating panel in pixels. If undefined {x:50, y:100} is used. |
size | SizeProps | defines the width and height of the floating panel. If undefined and widget has been floated before the previous size is used, else {height:400, width:400} is used. |
Returns - void
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.