useCreateRoot Method
When using React18, the createRoot
function must be provided in order to render Popout content with React18.
Do not call if using React 17 or before.
Note: The type of the function is intentionally simplified here.
useCreateRoot(createRootFn: CreateRoot): void
Parameter | Type | Description |
---|---|---|
createRootFn | CreateRoot | Function imported from import { createRoot } from "react-dom/client"; Will be removed once the transition to react 18 is complete. |
Returns - void
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.