getToolbarButtonItems MethodStatic
Called when the application is populating a toolbar so that any registered UiItemsProvider can add tool buttons that either either execute an action or specify a registered ToolId into toolbar.
getToolbarButtonItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): CommonToolbarItem[]
@returns an array of error messages. The array will be empty if the load is successful, otherwise it is a list of one or more problems.
Parameter | Type | Description |
---|---|---|
stageId | string | a string identifier the active stage. |
stageUsage | string | the StageUsage of the active stage. |
toolbarUsage | ToolbarUsage | usage of the toolbar |
toolbarOrientation | ToolbarOrientation | orientation of the toolbar |
stageAppData | any |
Returns - CommonToolbarItem[]
an array of error messages. The array will be empty if the load is successful, otherwise it is a list of one or more problems.
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.