AbstractStatusBarActionItem Interface

Deprecated  in 3.6. Use StatusBarActionItem instead.

Describes the data needed to insert an action item into the status bar.

Extends

Properties

Name Type Description
execute Readonly () => void method to execute when icon is pressed  
icon Readonly string | ConditionalStringValue Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id.  
label Readonly string | ConditionalStringValue Label.  
tooltip Readonly string | ConditionalStringValue tooltip.  

Inherited properties

Name Type Inherited from Description
applicationData Inherited any | undefined AbstractStatusBarItem can be used by application to store miscellaneous data.
badgeType Readonly Inherited BadgeType | undefined AbstractStatusBarItem Describes badge.
id Readonly Inherited string AbstractStatusBarItem Required unique id of the item.
internalData Readonly Inherited Map<string, any> | undefined AbstractStatusBarItem optional data to used by item implementor.
isDisabled Readonly Inherited boolean | ConditionalBooleanValue AbstractStatusBarItem Describes if the item is enabled or disabled.
isHidden Readonly Inherited boolean | ConditionalBooleanValue AbstractStatusBarItem Describes if the item is visible or hidden.
itemPriority Readonly Inherited number AbstractStatusBarItem Priority within a section (recommend using values 1 through 100).
providerId Readonly Inherited string | undefined AbstractStatusBarItem id of UiItemsProvider
section Readonly Inherited StatusBarSection AbstractStatusBarItem status bar section

Defined in

Last Updated: 21 November, 2024