AnalyticalSchema Class

Schema class for the Analytical domain.

Extends

  • Schema

Methods

Name Description
registerSchema(): void Static    

Inherited methods

Name Inherited from Description
toSemverString(paddedVersion: string): string Static Inherited Schema Get a semver-compatible string from a padded version string.

Properties

Name Type Description
schemaFilePath Accessor Static ReadOnly string TODO: Currently the schema file comes from a hardcoded path assuming its delivered with imodeljs-native  
schemaName Accessor Static ReadOnly string The name of the BIS schema handled by this Schema.  

Defined in

Last Updated: 26 April, 2025