core-frontend
Classes
Name | Description | |
---|---|---|
AccuDrawHintBuilder | AccuDrawHintBuilder is an InteractiveTool helper class that facilitates AccuDraw interaction. | |
AccuSnap | AccuSnap is an aide for snapping to interesting points on elements or decorations as the cursor moves over them. | |
Specifies the details of an activity message to be displayed to the user. | ||
AngleDescription | Angle Property Description | Beta |
AuxCoordSystem2dState | The state of an AuxCoordSystem2d element in the frontend | |
AuxCoordSystem3dState | The state of an AuxCoordSystem3d element in the frontend | |
AuxCoordSystemSpatialState | The state of an AuxCoordSystemSpatial element in the frontend | |
AuxCoordSystemState | The state of an AuxCoordSystem element in the frontend | |
BaseUnitFormattingSettingsProvider | This abstract class reacts to changes in the "active" iModel and updates the QuantityFormatter overrides and active | Beta |
BeButtonEvent | Object sent to Tools that holds information about button/touch/wheel events. | |
BeButtonState | ||
BeTouchEvent | A ButtonEvent generated by touch input. | |
BeWheelEvent | A BeButtonEvent generated by movement of a mouse wheel. | |
BingElevationProvider | Provides an interface to the Bing Maps elevation services. | |
BingLocationProvider | Provides an interface to the Bing Maps location services. | |
BlankConnection | A connection that exists without an iModel. | |
BriefcaseConnection | A connection to an editable briefcase on the backend. | |
BriefcaseNotificationHandler | Base class for notification handlers for events from the backend that are specific to a BriefcaseConnection. | |
BriefcaseTxns | Manages local changes to a BriefcaseConnection via Txns. | |
CategorySelectorState | A set of Categories to be displayed in a ViewState. | |
ChangeFlags | Describes which aspects of a Viewport have changed. | |
CheckpointConnection | An IModelConnection to a checkpoint of an iModel, hosted on a remote backend over RPC. | |
Cluster | A cluster of one or more Markers that overlap one another in the view. | |
ContextRealityModelState | A ContextRealityModel attached to a DisplayStyleState supplying a TileTreeReference used to draw the | |
DecorateContext | Provides context for a ViewportDecorator to add Decorations to be rendered within a Viewport. | |
Decorations | A set of RenderGraphics and CanvasDecorations produced by Tools and Decorators, used to decorate the contents of a Viewport. | |
DisclosedTileTreeSet | A set of TileTrees disclosed by a set of objects implementing TileTreeDiscloser, used to collect references to tile trees in use by those objects. | |
DisplayStyle2dState | A display style that can be applied to 2d views. | |
DisplayStyle3dState | A DisplayStyleState that can be applied to spatial views. | |
DisplayStyleState | A DisplayStyle defines the parameters for 'styling' the contents of a ViewState. | |
DrawingModelState | Represents the front-end state of a DrawingModel. | |
DrawingViewState | A view of a DrawingModel | |
DynamicsContext | Provides context for an InteractiveTool to display decorations representing its current state. | |
ElementLocateManager | ||
ElementPicker | ||
ElementState | The "state" of an Element as represented in a web browser. | |
EmphasizeElements | An implementation of FeatureOverrideProvider for emphasizing selected elements through simple color/transparency appearance overrides. | |
EngineeringLengthDescription | Engineering Length Property Description | Beta |
EntityState | The "state" of an Entity as represented in a web browser. | |
EventController | An EventController maps user input events from a Viewport to the ToolAdmin so that tools can process them. | |
FitViewTool | A tool that performs a fit view | |
FlashSettings | Settings that control how geometry is "flashed" when hovered over in a Viewport. | |
FlyViewTool | A tool that performs the fly operation | |
FormattedQuantityDescription | Base Quantity Property Description | Beta |
FrustumAnimator | Animates the transition of a Viewport from one Frustum to another. | |
FuzzySearch | ||
FuzzySearchResults | This class is used to return the results of FuzzySearch.search. | |
GeographicTilingScheme | A MapTilingScheme using a simple geographic projection by which longitude and latitude are mapped directly to X and Y. | Beta |
GeometricModel2dState | Represents the front-end state of a GeometricModel2d. | |
GeometricModel3dState | Represents the front-end state of a GeometricModel3d. | |
GeometricModelState | Represents the front-end state of a GeometricModel. | |
GlobeAnimator | Animates the transition of a Viewport to view a location on the Earth. | |
GraphicalEditingScope | Represents a period of time within an interactive editing session during which the | |
GraphicBranch | A node in a scene graph. | |
GraphicBuilder | Provides methods for constructing a RenderGraphic from geometric primitives. | |
HiliteSet | A set of hilited elements for an IModelConnection, by element id. | |
HitDetail | A HitDetail stores the result when locating geometry displayed in a view. | |
HitList | The result of a "locate" is a sorted list of objects that satisfied the search criteria (a HitList). | |
IconSprites | Icon sprites are loaded from .png files in the assets directory of imodeljs-native. | |
IdleTool | The default "idle" tool. | |
ImageryMapLayerFormat | Base class imagery map layer formats. | Beta |
IModelApp | Global singleton that connects the user interface with the iTwin.js services. | |
IModelConnection | A connection to a IModelDb hosted on the backend. | |
IModelRoutingContext | Controls the RPC routing for an iModel connection. | |
IndexBuffer | Builds up a VertexIndices. | |
InputCollector | The InputCollector class can be used to implement a command for gathering input | |
InteractiveTool | A Tool that may be installed, via ToolAdmin, to handle user input. | |
IntersectDetail | ||
IpcApp | The frontend of apps with a dedicated backend that can use Ipc. | |
LengthDescription | Length Property Description | Beta |
LocalUnitFormatProvider | Implementation of BaseUnitFormattingSettingsProvider that stores and retrieves data in local storage. | Beta |
LocateOptions | Options that customize the way element location (i.e. | |
LocateResponse | ||
LookAndMoveTool | A tool that performs the walk operation using mouse+keyboard or touch controls. | |
LookViewTool | A tool that performs the look operation | |
MapCartoRectangle | A specialization of Range2d representing a Cartographic region on the surface of the Earth, | Beta |
MapLayerFormat | Class representing a map-layer format. | Beta |
MapLayerFormatRegistry | Beta | |
MapLayerSource | A source for map layers. | |
MapTile | A Tile belonging to a MapTileTree representing a rectangular region of a map of the Earth. | Beta |
MapTileProjection | Projects points within the rectangular region of a MapTile into 3d space. | Beta |
MapTileTree | A quad tree consisting of MapTiles representing the map imagery draped onto the surface of the Earth. | Beta |
MapTilingScheme | A scheme for converting between two representations of the surface of the Earth: an ellipsoid and a rectangular tiled map. | Beta |
MarginPercent | Specifies margins to apply around a view volume for methods like ViewState.lookAtVolume and Viewport.zoomToElements, expanding the | |
Marker | A Marker is a CanvasDecoration, whose position follows a fixed location in world space. | |
MarkerSet | A set of Markers that are logically related, such that they cluster when they overlap one another in screen space. | |
MeasureAreaByPointsTool | Report area defined by points using current quantity formatter for area. | |
MeasureAreaTool | Report accumulated areas of selected elements using the current quantity formatter for area. | |
MeasureDistanceTool | Report distance between 2 points using current quantity formatter for length. | |
MeasureElementTool | Base class for mass properties tools. | |
MeasureLengthTool | Report accumulated lengths of selected elements using the current quantity formatter for length. | |
MeasureLocationTool | Report spatial coordinate at a point as well as cartographic location for geolocated models using current quantity formatters. | |
MeasureVolumeTool | Report accumulated volumes of selected elements using the current quantity formatter for volume. | |
MeshParams | Describes mesh geometry to be submitted to the rendering system. | |
ModelSelectorState | The state of a ModelSelector. | |
ModelState | Represents the front-end state of a Model. | |
NativeApp | The frontend of a native application | |
NotificationHandler | Base class for all implementations of an Ipc notification response interface. | |
NotificationManager | The NotificationManager controls the interaction with the user for prompts, error messages, and alert dialogs. | |
Describes a message to be displayed to the user. | ||
OffScreenViewport | A viewport that draws to an offscreen buffer instead of to the screen. | |
OrthographicViewState | Defines a spatial view that displays geometry on the image plane using a parallel orthographic projection. | |
PanViewTool | The tool that performs a Pan view operation | |
PhysicalModelState | Represents the front-end state of a PhysicalModel. | |
PlanarClipMaskState | The State of Planar Clip Mask applied to a reality model or background map. | Beta |
PolylineParams | Describes a set of tesselated polylines. | |
PrimitiveTool | The PrimitiveTool class can be used to implement tools to create or modify geometric elements. | |
QuadId | Identifies a node within a quad tree, such as a MapTile within a MapTileTree. | Beta |
QuantityFormatter | Class that supports formatting quantity values into strings and parsing strings into quantity values. | |
RealityMeshParamsBuilder | Incrementally constructs a RealityMeshParams. | Beta |
RealityTile | A Tile within a RealityTileTree, representing part of a reality model (e.g., a point cloud or photogrammetry mesh) or 3d terrain with map imagery. | Beta |
RealityTileTree | Base class for a TileTree representing a reality model (e.g., a point cloud or photogrammetry mesh) or 3d terrain with map imagery. | Beta |
RenderClipVolume | An opaque representation of a clip volume applied to geometry within a Viewport. | |
RenderContext | Provides context for producing RenderGraphics for drawing within a Viewport. | |
RenderGraphic | Abstract representation of an object which can be rendered by a RenderSystem. | |
RenderGraphicOwner | A graphic that owns another graphic. | |
RenderSystem | A RenderSystem provides access to resources used by the internal WebGL-based rendering system. | |
RotateViewTool | A tool that performs a Rotate view operation | |
Scene | Holds a collection of objects comprising the scene to be drawn by a Viewport's. | |
SceneContext | Context used to create the scene to be drawn in a Viewport. | |
ScreenViewport | An interactive Viewport that exists within an HTMLDivElement. | |
ScrollViewTool | A tool that performs the scroll operation | |
SectionDrawingModelState | Represents the front-end state of a SectionDrawingModel. | |
SelectionSet | A set of currently selected elements for an IModelConnection. | |
SelectionTool | Tool for picking a set of elements of interest, selected by the user. | |
SetupCameraTool | A tool that sets the view camera by two points. | |
SetupWalkCameraTool | A tool that sets a walk tool starting position by a floor point and look direction. | |
SheetModelState | Represents the front-end state of a SheetModel. | |
SheetViewState | A view of a SheetModel. | |
SnapDetail | A SnapDetail is generated from the result of a snap request. | |
SnapshotConnection | A connection to a SnapshotDb hosted on a backend. | |
SpatialLocationModelState | Represents the front-end state of a SpatialLocationModel. | |
SpatialModelState | Represents the front-end state of a SpatialModel. | |
SpatialViewState | Defines a view of one or more SpatialModels. | |
Sprite | Sprites are small raster images that are drawn on top of Viewports by a ViewDecoration. | |
SpriteLocation | A Sprite location. | |
StandardView | Supplies access to a set of commonly-used view rotations. | |
StandardViewTool | A tool that rotates the view to one of the standard views. | |
Storage | A local disk-based cache for key value pairs for NativeApps. | |
SurveyLengthDescription | Survey Length Property Description | Beta |
TentativePoint | ||
TerrainMeshProvider | Provides 3d meshes representing terrain for display in a Viewport. | Beta |
TerrainProviderRegistry | A registry of TerrainProviders identified by their unique names. | Beta |
Tile | A 3d tile within a TileTree. | |
TileAdmin | Manages Tiles and TileTrees on behalf of IModelApp. | |
TileDrawArgs | Provides context used when selecting and drawing Tiles. | |
TileGeometryCollector | Collects geoemtry from a GeometryTileTreeReference within a specified volume at a specified level of detail. | Beta |
TileRequest | Represents a pending or active request to load the contents of a Tile. | |
TileRequestChannel | A channel over which requests for tile content can be made. | |
TileRequestChannels | A set of named TileRequestChannels via which content for Tiles can be requested. | |
TileRequestChannelStatistics | Statistics regarding the current and cumulative state of one or more TileRequestChannels. | |
Tiles | Provides access to TileTrees associated with an IModelConnection. | |
TileStorage | Beta | |
TileTree | A hierarchical level-of-detail tree of 3d Tiles to be rendered in a Viewport. | |
TileTreeReference | A reference to a TileTree suitable for drawing within a Viewport. | |
TileUsageMarker | A marker associated with a Tile to track usage of that tile by any number of TileUsers. | |
Tool | A Tool that performs an action. | |
ToolAdmin | Controls the operation of Tools, administering the current ViewTool, PrimitiveTool, and IdleTool and forwarding events to the appropriate tool. | |
ToolAssistance | Tool Assistance helper methods. | |
ToolRegistry | The ToolRegistry holds a mapping between toolIds and their corresponding Tool class. | |
ToolSettings | Settings that control the behavior of built-in tools. | |
TwoWayViewportFrustumSync | Forms a bidirectional connection between two Viewports such that the Frustums of each are synchronized with one another. | |
TwoWayViewportSync | Forms a bidirectional connection between two Viewports such that the ViewStates of each are synchronized with one another. | |
VertexTableBuilder | Builds a VertexTable from some data type supplying the vertex data. | |
ViewClipByElementTool | A tool to define a clip volume for a view using the element aligned box or axis aligned box. | |
ViewClipByPlaneTool | A tool to define a clip volume for a view by specifying a plane | |
ViewClipByRangeTool | A tool to define a clip volume for a view by specifying range corners | |
ViewClipByShapeTool | A tool to define a clip volume for a view by specifying a shape | |
ViewClipClearTool | A tool to remove a clip volume for a view | |
ViewClipDecorationProvider | An implementation of ViewClipEventHandler that responds to new clips by presenting clip modification handles | |
ViewClipTool | A tool to define a clip volume for a view | |
ViewCreator2d | API for creating a ViewState2d for a 2D model (GeometricModel2dState). | |
ViewCreator3d | API for creating a 3D default ViewState3d for an iModel. | |
ViewGlobeBirdTool | A tool that views a location on the background map from a bird's eye perspective; the viewed location is derived from the position of the current camera's eye above the background map. | |
ViewGlobeIModelTool | A tool that views the current iModel on the background map so that the extent of the project is visible. | |
ViewGlobeLocationTool | A tool that views a location on the background map corresponding to a specified string. | |
ViewGlobeSatelliteTool | A tool that views a location on the background map from a satellite's perspective; the viewed location is derived from the position of the current camera's eye above the background map. | |
ViewingSpace | Describes a Viewport's viewing volume, plus its size on the screen. | |
ViewManager | The ViewManager holds the list of opened views, plus the selected view. | |
ViewManip | Base class for tools that manipulate the frustum of a Viewport. | |
Viewport | A Viewport renders the contents of one or more GeometricModels onto an HTMLCanvasElement . |
|
ViewPose | The "pose" for a View describing the viewed area or volume, depending upon whether | |
ViewPose2d | The "pose" for a ViewState2d. | |
ViewPose3d | The "pose" for a ViewState3d, including information about the view's Camera if it is enabled. | |
ViewRect | A rectangle in unsigned integer view coordinates with (0,0) corresponding to the top-left corner of the view. | |
ViewRedoTool | A tool that performs view redo operation. | |
ViewState | The front-end state of a ViewDefinition element. | |
ViewState2d | Defines the state of a view of a single 2d model. | |
ViewState3d | Defines the state of a view of 3d models. | |
ViewToggleCameraTool | A tool that toggles the camera on/off in a spatial view | |
ViewTool | An InteractiveTool that manipulates a view. | |
ViewUndoTool | A tool that performs view undo operation. | |
WalkViewTool | A tool that performs the walk operation | |
WebMercatorTilingScheme | A MapTilingScheme using the EPSG:3857 projection. | Beta |
WindowAreaTool | A tool that performs a Window-area view operation | |
ZoomViewTool | A tool that performs the zoom operation |
Constants
Name | Description | |
---|---|---|
iModelJsCss | ||
ITWINJS_CORE_VERSION | ||
UNIT_EXTRA_DATA | Additional unit data such alternate display label not found in the Units Schema |
Enumerations
Name | Description | |
---|---|---|
ACSDisplayOptions | ||
ACSType | ||
Reason for ending the activity message via endActivityMessage | ||
BeButton | ||
BeModifierKeys | Numeric mask for a set of modifier keys (control, shift, and alt). | |
ClipEventType | Event types for ViewClipDecorationProvider.onActiveClipChanged \ | |
ContextRotationId | Specify the rotation to return from AccuDrawHintBuilder.getContextRotation. | |
CoordinateLockOverrides | ||
CoordSource | The source that generated a coordinate. | |
CoordSystem | Coordinate system types | |
DepthPointSource | Source of depth point returned by Viewport.pickDepthPoint. | |
EventHandled | ||
FlashMode | As part of FlashSettings, describes how geometry is flashed. | |
FrontendLoggerCategory | Logger categories used by this package | |
GraphicType | Describes the type of a GraphicBuilder, which defines the coordinate system in which the builder's geometry is defined and | |
HitDetailType | ||
HitGeomType | What was being tested to generate this hit. | |
HitParentGeomType | Classification of GeometricPrimitive that generated the Hit. | |
HitPriority | ||
HitSource | The procedure that generated this Hit. | |
InputSource | The source that generated an event. | |
KeyinParseError | Possible errors resulting from ToolRegistry.parseKeyin. | |
LocateAction | The possible actions for which a locate filter can be called. | |
LocateFilterStatus | Values to return from a locate filter. | |
ManipulatorToolEvent | ||
MapLayerImageryProviderStatus | Beta | |
MapLayerSourceStatus | Values for return codes from MapLayerSource.validateSource | |
MapTileTreeScaleRangeVisibility | Map tile tree scale range visibility values. | Beta |
Describes the icon displayed in a messagebox opened using NotificationManager.openMessageBox. | ||
Describes the set of buttons displayed in a message box opened using NotificationManager.openMessageBox. | ||
Describes the possible return values produced when the user clicks a button in a messagebox opened using NotificationManager.openMessageBox. | ||
Describes the alert behavior of a NotifyMessageDetails. | ||
Classifies a NotifyMessageDetails by its level of importance. | ||
Describes the type and behavior of a NotifyMessageDetails. | ||
ParseAndRunResult | The result type of ToolRegistry.parseAndRun. | |
QuantityType | Defines standard format types for tools that need to display measurements to user. | |
SelectionMethod | The method for choosing elements with the SelectionTool | |
SelectionMode | The mode for choosing elements with the SelectionTool | |
SelectionProcessing | The processing method to use to update the current selection. | |
SelectionSetEventType | Identifies the type of changes made to the SelectionSet to produce a SelectionSetEvent. | |
SnapHeat | ||
SnapMode | ||
SnapStatus | ||
StandardViewId | Describes a set of commonly-used view rotations. | |
StartOrResume | ||
TileBoundingBoxes | Options for displaying tile bounding boxes for debugging purposes. | |
TileGraphicType | Describes the type of graphics produced by a TileTreeReference. | |
TileLoadPriority | Loosely describes the "importance" of a Tile. | |
TileLoadStatus | Describes the current status of a Tile's content. | |
TileTreeLoadStatus | Describes the current state of a TileTree. | |
TileVisibility | Describes the visibility of a tile based on its size and a view frustum. | |
ToolAssistanceImage | Tool Assistance known images | |
ToolAssistanceInputMethod | Input Method for Tool Assistance instruction | |
UniformType | The underlying data types that can be used for uniform variables in screen-space effect shaders. | |
VaryingType | The underlying data types that can be used for varying variables in screen-space effect shaders. | |
ViewStatus | Describes the result of a viewing operation such as those exposed by ViewState and Viewport. | |
ViewUndoEvent | Describes an undo or redo event for a Viewport. |
Global Functions
Name | Description | |
---|---|---|
calculateEcefToDbTransformAtLocation | Calculate the ECEF to database (IModel) coordinate transform at a provided location, using the GCS of the iModel. | |
calculateEdgeTableParams | ||
canvasToImageBuffer | Create an ImageBuffer in the specified format with the same dimensions and contents as a canvas. | |
canvasToResizedCanvasWithBars | Resize a canvas to a desired size. | |
connectViewportFrusta | Form a connection between two or more Viewports such that they all view the same volume. | |
connectViewports | Forms a connection between two or more Viewports such that a change in any one of the viewports is reflected in all of the others. | |
connectViewportViews | Form a connection between two or more Viewports such that every aspect of the viewports are kept in sync. | |
extractImageSourceDimensions | Extract the dimensions of the jpeg or png data encoded in an ImageSource. | |
getCenteredViewRect | Determine the maximum ViewRect that can be fitted and centered in specified ViewRect given a required aspect ratio. | |
getCesiumAssetUrl | Return the URL for a Cesium ION asset from its asset ID and request Key. | |
getCompressedJpegFromCanvas | Produce a jpeg compressed to no more than specified bytes and of no less than specified quality. | |
getImageSourceFormatForMimeType | Get the ImageSourceFormat corresponding to the mime type string, or undefined if the string does not identify a supported ImageSourceFormat. | |
getImageSourceMimeType | Get a string describing the mime type associated with an ImageSource format. | |
getQuantityTypeKey | Function to return a QuantityTypeKey given either a QuantityType enum value or a string. | |
imageBitmapFromImageSource | Extract a bitmap from a binary jpeg or png. | |
imageBufferToBase64EncodedPng | Converts the contents of an ImageBuffer to PNG format. | |
imageBufferToCanvas | Create a canvas element with the same dimensions and contents as an image buffer. | |
imageBufferToPngDataUrl | Produces a data url in "image/png" format from the contents of an ImageBuffer. | |
imageElementFromImageSource | Extract an html Image element from a binary jpeg or png. | |
imageElementFromUrl | Create an html Image element from a URL. | |
isCheckboxFormatPropEditorSpec | CheckboxFormatPropEditorSpec type guard. | |
isCustomQuantityTypeDefinition | CustomQuantityTypeDefinition type guard. | |
isTextInputFormatPropEditorSpec | TextInputFormatPropEditorSpec type guard. | |
isTextSelectFormatPropEditorSpec | TextSelectFormatPropEditorSpec type guard. | |
openImageDataUrlInNewWindow | Open an image specified as a data URL in a new window or tab. | Beta |
queryTerrainElevationOffset | Queries the actual elevation of a cartographic point on the globe (using Bing elevation services) | |
readElementGraphics | Convert the byte array returned by TileAdmin.requestElementGraphics into a RenderGraphic. | |
readGltfGraphics | Produce a RenderGraphic from a glTF asset suitable for use in view decorations. | |
splitMeshParams | ||
splitPolylineParams | ||
synchronizeViewportFrusta | A function that returns a SynchronizeViewports function that synchronizes the viewed volumes of each viewport. | |
synchronizeViewportViews | A function that returns a SynchronizeViewports function that synchronizes every aspect of the viewports' states, including | |
tesselatePolyline | Strictly for tests. | |
tryImageElementFromUrl | Try to create an html Image element from a URL. | |
upsampleRealityMeshParams | ||
wantJointTriangles |
Interfaces
Name | Description | |
---|---|---|
Animator | An object to animate a transition of a Viewport. | |
BatchOptions | Options used when constructing a Batch - that is, a RenderGraphic with an associated FeatureTable describing individual Features within the |
|
BeButtonEventProps | Properties for constructing a BeButtonEvent | |
BeTouchEventProps | Properties for initializing a BeTouchEvent | |
BeWheelEventProps | Properties for constructing a BeWheelEvent | |
BlankConnectionProps | The properties for creating a Blank IModelConnection | |
CanvasDecoration | A Decoration that is drawn onto the | |
ChangeViewedModel2dOptions | Options for changing the viewed Model of a 2d view via Viewport.changeViewedModel2d | |
CheckboxFormatPropEditorSpec | CheckboxFormatPropEditorSpec defines getter and setter method for a boolean property editor. | |
ComputeChordToleranceArgs | Arguments used to compute the chord tolerance (level of detail) of the RenderGraphics produced by a GraphicBuilder. | |
ComputeDisplayTransformArgs | Arguments supplied to ViewState.computeDisplayTransform. | Beta |
CreateRenderMaterialArgs | Arguments supplied to RenderSystem.createRenderMaterial. | |
CreateTextureArgs | Arguments supplied to RenderSystem.createTexture to create a RenderTexture. | |
CreateTextureFromSourceArgs | Arguments supplied to RenderSystem.createTextureFromSource. | |
CustomFormatPropEditorSpec | Properties that define an EditorSpec for editing a custom formatting property that is stored in the "custom" property in the FormatProps. | |
CustomGraphicBuilderOptions | Options for creating a GraphicBuilder to produce a RenderGraphic that is not associated with any particular Viewport and may not be associated with | |
CustomQuantityTypeDefinition | CustomQuantityTypeDefinition interface is used to define a Custom quantity type that can be registered with the QuantityFormatter. | |
Decorator | Interface for drawing decoration graphics into, or on top of, the active ScreenViewports managed by ViewManager. | |
DepthPointOptions | Options to control behavior of Viewport.pickDepthPoint. | |
DepthRangeNpc | The minimum and maximum values for the z-depth of a rectangle of screen space. | |
DownloadProgressInfo | Download progress information. | |
EdgeParams | Describes the edges of a mesh. | |
EdgeTableInfo | ||
ExtentLimits | Describes the largest and smallest values allowed for the extents of a ViewState. | |
FeatureOverrideProvider | An object that customizes the appearance of Features within a Viewport using FeatureSymbology.Overrides. | |
FormatterParserSpecsProvider | Interface that defines the functions required to be implemented to provide custom formatting and parsing of a custom quantity type. | |
FormattingUnitSystemChangedArgs | Arguments sent to FormattingUnitSystemChanged event listeners. | |
FrontendHubAccess | ||
FrontendSecurityOptions | Options that can be supplied with IModelAppOptions to customize frontend security. | |
FuzzySearchResult | Interface implemented by objects returned while iterating through FuzzySearchResults | |
GenericAbortSignal | Partial interface of AbortSignal. | Beta |
GeometryTileTreeReference | A TileTreeReference that can supply geometry in the form of Polyfaces from Tiles belonging to its TileTree and satisfying the criteria defined | Beta |
GetPixelDataWorldPointArgs | Arguments to Viewport.getPixelDataWorldPoint. | |
GlobalAlignmentOptions | Options that control how a view is aligned with the globe. | |
GlobalLocation | Describes a location on the earth using cartographic data structures. | |
GlobalLocationArea | Describes a rectangular area of the earth using cartographic data structures. | |
GltfMeshPrimitive | A unit of geometry belonging to a GltfMesh. | |
GltfNodeBaseProps | Properties common to Gltf1Node and Gltf2Node. | |
GltfTextureInfo | Describes a reference to a GltfTexture. | |
GpuMemoryLimits | Defines separate GpuMemoryLimits for mobile and desktop clients. | |
GraphicArc | A GraphicPrimitive representing a 3d open arc or closed ellipse that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicArc2d | A GraphicPrimitive representing a 2d open arc or closed ellipse that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicBranchOptions | Options passed to RenderSystem.createGraphicBranch. | |
GraphicBuilderOptions | Options for creating a GraphicBuilder used by functions like DecorateContext.createGraphic and RenderSystem.createGraphic. | |
GraphicLineString | A GraphicPrimitive representing a line string that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicLineString2d | A GraphicPrimitive representing a 2d line string that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicLoop | A GraphicPrimitive representing a 3d planar region that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicPath | A GraphicPrimitive representing a 3d open path that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicPointString | A GraphicPrimitive representing a point string that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicPointString2d | A GraphicPrimitive representing a 2d point string that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicPolyface | A GraphicPrimitive representing a mesh that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicPrimitive2d | Base interface for a 2d GraphicPrimitive that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicShape | A GraphicPrimitive representing a closed 3d planar region that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicShape2d | A GraphicPrimitive representing a closed 2d region that can be supplied to GraphicBuilder.addPrimitive. | |
GraphicSolidPrimitive | A GraphicPrimitive representing a SolidPrimitive to be supplied to GraphicBuilder.addPrimitive. | |
HitListHolder | ||
IModelAppOptions | Options that can be supplied to IModelApp.startup to customize frontend behavior. | |
IModelIdArg | ||
IpcAppOptions | Options for IpcApp.startup | |
ITwinIdArg | Argument for methods that can supply an iTwinId and iModelId. | Beta |
LookAtArgs | Arguments to ViewState3d.lookAt for either a perspective or orthographic view | |
LookAtOrthoArgs | Arguments to ViewState3d.lookAt to set up an orthographic view | |
LookAtPerspectiveArgs | Arguments to ViewState3d.lookAt to set up a perspective view | |
LookAtUsingLensAngle | Arguments to ViewState3d.lookAt to set up an perspective view using a (field-of-view) lens angle. | |
MapLayerAccessClient | Beta | |
MapLayerAccessToken | Beta | |
MapLayerAccessTokenParams | Beta | |
MapLayerAuthenticationInfo | Beta | |
MapLayerOptions | Options supplied at startup via IModelAppOptions.mapLayerOptions to specify access keys for various map layer formats. | Beta |
MapLayerScaleRangeVisibility | MapLayer visibility based on its scale range definition. | Beta |
MapLayerSourceValidation | ||
MapLayerTokenEndpoint | Beta | |
MarginOptions | Options that control the margin around the edges of a volume for lookAt and Fit view operations | |
MaterialDiffuseProps | Describes the diffuse properties of a RenderMaterial. | |
MaterialSpecularProps | Describes the specular properties of a material. | |
MaterialTextureMappingProps | Describes how to map a RenderTexture's image to the surfaces to which a RenderMaterial is applied. | |
MeshArgs | ||
ModelDisplayTransformProvider | Interface adopted by an object that wants to apply per-model display transforms. | Beta |
NativeAppOpts | Options for NativeApp.startup | |
OffScreenViewportOptions | Options supplied when creating an OffScreenViewport. | |
OnViewExtentsError | A method to be called if an error occurs while adjusting a ViewState's extents | |
OsmBuildingDisplayOptions | Options controlling display of OpenStreetMap Buildings. | |
OverrideFormatEntry | Override format entries can define formats for any of the different unit systems. | |
PaddingPercent | Specifies padding to apply around a view volume for methods like ViewState.lookAtVolume and Viewport.zoomToElements, expanding or | |
ParsedKeyin | Successful result from ToolRegistry.parseKeyin. | |
ParseKeyinError | Possible errors form ToolRegistry.parseKeyin. | |
ParticleCollectionBuilder | Interface for producing a collection of particles suitable for use in particle effects. | |
ParticleCollectionBuilderParams | Parameters used to construct a ParticleCollectionBuilder. | |
ParticleProps | Describes a particle to to add to a particle collection via ParticleCollectionBuilder.addParticle. | |
PickableGraphicOptions | Options used as part of GraphicBuilderOptions to describe a pickable RenderGraphic. | |
PointCloudArgs | ||
PolylineArgs | ||
PreferenceArg | Argument for methods that can supply the user preference content. | Beta |
PreferenceKeyArg | Argument for methods that must supply a key for the user preference. | Beta |
PullChangesOptions | Options for pulling iModel changes. | |
QuantityFormatOverridesChangedArgs | Arguments sent to UnitFormattingSettingsProvider when overrides are changed. | |
QuantityFormatsChangedArgs | Arguments sent to QuantityFormatsChanged event listeners. | |
QuantityTypeDefinition | This interface supplies the definition of a standard quantity type that is registered with the QuantityFormatter. |
|
QueryScreenFeaturesOptions | Options specifying how to query for visible Features by reading pixels rendered by a Viewport. | |
QueryTileFeaturesOptions | Options specifying how to query for visible Features by inspecting the Tiles selected for display by a Viewport. | |
ReadGltfGraphicsArgs | Arguments supplied to readGltfGraphics to produce a RenderGraphic from a glTF asset. | |
ReadImageBufferArgs | Arguments supplied to Viewport.readImageBuffer. | |
ReadMeshArgs | Arguments supplied to TerrainMeshProvider.readMesh. | Beta |
RealityDataSource | This interface provide methods used to access a reality data from a reality data provider | Beta |
RealityMeshParams | Geometry for a reality mesh to be submitted to the RenderSystem for conversion to a RenderGraphic. | Beta |
RealityMeshParamsBuilderOptions | Options used to construct a RealityMeshParamsBuilder. | Beta |
RenderSystemDebugControl | An interface optionally exposed by a RenderSystem that allows control of various debugging features. | Beta |
RequestMeshDataArgs | Arguments supplied to TerrainMeshProvider.requestMeshData. | Beta |
ScreenSpaceEffectBuilder | An interface used to construct and register with the IModelApp.renderSystem a custom screen-space effect. | |
ScreenSpaceEffectBuilderParams | Parameters used to create a ScreenSpaceEffectBuilder. | |
ScreenSpaceEffectContext | Context passed to ScreenSpaceEffectBuilder.shouldApply. | |
ScreenSpaceEffectSource | The GLSL implementation of the effect produced by a ScreenSpaceEffectBuilder, to be integrated into a complete shader program. | |
SelectAddEvent | Passed to SelectionSet.onChanged event listeners when elements are added to the selection set. | |
SelectedViewportChangedArgs | Argument for ViewManager.onSelectedViewportChanged | |
SelectRemoveEvent | Passed to SelectionSet.onChanged event listeners when elements are removed from the selection set. | |
SelectReplaceEvent | Passed to SelectionSet.onChanged event listeners when elements are simultaneously added to and removed from the selection set. | |
SplitMeshArgs | ||
SplitPointStringArgs | ||
SplitPolylineArgs | ||
SplitVertexTableArgs | ||
TerrainMeshProviderOptions | Options supplied to TerrainProvider.createTerrainMeshProvider to construct a TerrainMeshProvider. | Beta |
TerrainProvider | Interface adopted by an object that can supply TerrainMeshProviders enabling the display of 3d terrain in a Viewport. | Beta |
TextInputFormatPropEditorSpec | TextInputFormatPropEditorSpec defines getter and setter method for a text input property editor. | |
TextSelectFormatPropEditorSpec | TextSelectFormatPropEditorSpec defines getter and setter method for a Select/Dropdown property editor. | |
TextureCacheOwnership | Specifies that a RenderTexture should be kept in memory until the corresponding IModelConnection is closed, at | |
TextureImage | Describes the image from which to create a RenderTexture. | |
TileContent | Describes the contents of a Tile. | |
TiledGraphicsProvider | Provides a way for applications to inject additional non-decorative graphics into a Viewport by supplying one or more TileTreeReferences capable of loading and drawing the graphics. | |
TileDrawArgParams | Parameters used to construct TileDrawArgs. | |
TileGeometryCollectorOptions | Options for creating a TileGeometryCollector. | Beta |
TileParams | Parameters used to construct a Tile. | |
TileTreeDiscloser | Interface adopted by an object that contains references to TileTrees, to expose those trees. | |
TileTreeOwner | Owns and manages the lifecycle of a TileTree. | |
TileTreeParams | Parameters used to construct a TileTree. | |
TileTreeSupplier | Interface adopted by an object which can supply a TileTree for rendering. | |
TileUser | Represents some object that makes use of Tiles in some way - e.g., by requesting and/or displaying their contents, querying their geometry, etc. | |
TokenArg | Argument for methods that can supply an access token. | Beta |
ToolAssistanceInstruction | Interface used to describe a Tool Assistance instruction. | |
ToolAssistanceInstructions | Interface used to describe Tool Assistance for a tool's state. | |
ToolAssistanceKeyboardInfo | Tool Assistance image keyboard keys | |
ToolAssistanceSection | Interface used to describe a Tool Assistance section with a label and a set of instructions. | |
ToolTipOptions | Describes the behavior of a tooltip created using NotificationManager.openToolTip. | |
Uniform | Represents a uniform variable in a shader program used by a custom screen-space effect, providing methods for setting the current value of the uniform. | |
UniformArrayParams | Parameters used to define an array of uniform variables for a ScreenSpaceEffectBuilder's shader program. | |
UniformContext | Context supplied to UniformParams.bind. | |
UniformParams | Parameters used to define a uniform variable for a ScreenSpaceEffectBuilder's shader program. | |
UnitFormattingSettingsProvider | The UnitFormattingSettingsProvider interface is used to store and retrieve override FormatProps and Presentation Unit System | |
UpsampledRealityMeshParams | ||
UserPreferencesAccess | User preferences provide a way to get, store and delete preferences for an application at | Beta |
ViewAnimationOptions | Options that control how an Viewport animation behaves. | |
ViewChangeOptions | Options that control how operations that change a viewport behave. | |
ViewClipEventHandler | An object that can react to a view's clip being changed by tools or modify handles. | |
ViewCreator2dOptions | Options for creating a ViewState2d via ViewCreator2d. | |
ViewCreator3dOptions | Options for creating a ViewState3d via ViewCreator3d. | |
ViewportDecorator | Interface for drawing Decorations into, or on top of, a ScreenViewport. | |
ViewportGraphicBuilderOptions | Options for creating a GraphicBuilder to produce a RenderGraphic to be displayed in a specific Viewport. | |
VisibleFeature | Represents a Feature determined to be visible within a Viewport. | |
ZoomToOptions | Options to allow changing the view rotation with zoomTo methods. |
Namespaces
Name | Description | |
---|---|---|
AccuSnap | ||
EditManipulator | Classes and methods to create on screen control handles for interactive modification of element(s) and pickable decorations. | |
FeatureSymbology | Contains types that enable an application to customize how Features are drawn within a Viewport. | |
Frustum2d | Constants and functions for working with two-dimensions Frustums. | |
IModelConnection | ||
ParticleCollectionBuilder | ||
PerModelCategoryVisibility | Per-model category visibility permits the visibility of categories within a Viewport displaying a SpatialViewState to be overridden in | |
Pixel | Describes aspects of a pixel as read from a Viewport. | |
RealityDataSource | Utility functions for RealityDataSource | Beta |
RealityMeshParams | Beta | |
RenderSystem | A RenderSystem provides access to resources used by the internal WebGL-based rendering system. | |
TesselatedPolyline | ||
TileAdmin | ||
TiledGraphicsProvider | ||
TileRequest | ||
TileUser |
Type Aliases
Name | Description | |
---|---|---|
CanvasDecorationList | An array of CanvasDecorations. | |
CollectTileStatus | Enumerates the statuses returned by TileGeometryCollector.collectTile. | Beta |
DownloadBriefcaseId | Properties for specifying the BriefcaseId for downloading. | |
DownloadBriefcaseOptions | Options to download a briefcase | |
FlashSettingsOptions | Options used to construct or clone a FlashSettings. | |
Gltf1Id | The type used to refer to an entry in a GltfDictionary in a glTF 1.0 asset. | |
Gltf2Id | The type used to refer to an entry in a GltfDictionary in a glTF 2.0 asset. | |
GltfId | The type used to refer to an entry in a GltfDictionary. | |
GpuMemoryLimit | Describes a strategy for imposing limits upon the amount of GPU memory consumed by Tile content. | |
GraphicList | An array of RenderGraphics. | |
GraphicPrimitive | Union type representing a graphic primitive that can be supplied to GraphicBuilder.addPrimitive. | |
MapLayerFormatType | Beta | |
MarkerFillStyle | ||
MarkerImage | The types that may be used for Markers | |
MarkerTextAlign | ||
MarkerTextBaseline | ||
ModelSubCategoryHiliteMode | Describes how the sets of hilited models and subcategories in a HiliteSet interact. | |
OnDownloadProgress | ||
OnFlashedIdChangedEventArgs | Payload for the Viewport.onFlashedIdChanged event indicating Ids of the currently- and/or previously-flashed objects. | |
ParseKeyinResult | The result type of ToolRegistry.parseKeyin. | |
QuantityTypeArg | Used to uniquely identify the type or quantity. | |
QuantityTypeKey | String used to uniquely identify a QuantityType in the quantity registry. | |
QueryVisibleFeaturesCallback | ||
QueryVisibleFeaturesOptions | Options specifying how to query for visible Features. | |
SelectionSetEvent | Payload sent to SelectionSet.onChanged event listeners to describe how the contents of the set have changed. | |
SynchronizeViewports | ||
TextureCacheKey | A key that uniquely identifies a RenderTexture in the context of an IModelConnection, used for caching. | |
TextureImageSource | An object from which a RenderTexture can be created. | |
TextureOwnership | Describes the ownership of a RenderTexture, which controls when the texture is disposed of. | |
ToolList | ||
ToolType | ||
UnitNameKey | String used to uniquely identify a UnitProp. |
Last Updated: 30 November, 2023