EdgeParams Interface
Describes the edges of a mesh.
Properties
Name | Type | Description | |
---|---|---|---|
indexed Readonly | undefined | | Silhouettes and simple-segment edges, compactly represented as indices into a lookup table. | |
linePixels Readonly | LinePixels | The line pattern in which edges are drawn. | |
polylines Readonly | undefined | | Polyline edges, always displayed when edge display is enabled. | |
segments Readonly | undefined | | Simple single-segment edges, always displayed when edge display is enabled. | |
silhouettes Readonly | undefined | | Single-segment edges of curved surfaces, displayed based on edge normal relative to eye. | |
weight Readonly | number | The edge width in pixels. |
Defined in
Last Updated: 30 November, 2023